HP Deskjet 5650 & NT 4.0

I don’t care what the HP site says but I have failed to get the HP Deskjet 5650 to work properly with NT 4.0. Sure 4.0 is old and I don’t care if they don’t support it, they should just not list it. This happened on more than 1 PC some I’m sure its a driver issue. It works fine on 2K up. Personally I think we should upgrade the few remaining NT4 workstations to 2K or XP anyway. Just a little help for the other IT guys out there.